Everything is broken (a delicious lego meme)

How to fix a Logic App deployment that failed with error “UsageConfigurationNotSupportedInSubscription”?

This article explains a quick and dirty fix when you get an error somewhat like “UsageConfigurationNotSupportedInSubscription” when you’re deploying an Azure Logic app from a template. The same fix will probably apply to a number of other issues – but don’t hold me accountable for this :) Anyway – on to the topic of the day! Problem Can you tell by some of my recent blog posts that I’ve been deploying a few Logic Apps recently? :) Today, my Azure Logic App deployment from a…Continue reading How to fix a Logic App deployment that failed with error “UsageConfigurationNotSupportedInSubscription”?

Azure Logic Apps logo

How to move your Microsoft PowerAutomate Flow to Logic Apps?

This article explains how you can export a Microsoft Power Automate Flow from, well, Microsoft Power Automate, and nicely and easily import it to Azure Logic Apps. I’ll explain the process step-by-step, and also explain solutions to a few hurdles you might run into! But first, let’s take a look at why you might want to consider taking this step in the first place, shall we? Why move to Logic Apps? Ah, a valid question. There are plenty of possible reasons why you might want…Continue reading How to move your Microsoft PowerAutomate Flow to Logic Apps?

Everything is broken (a delicious lego meme)

How to fix a Logic App deployment that failed with error “ApiNotFound”?

This article explains a quick and dirty fix when you get an error somewhat like “ApiNotFound” when you’re deploying an Azure Logic app from a template. This seems to be a very typical hurdle to run into when you’re trying to deploy a PowerAutomate Flow you’ve exported. I guess despite being built on the same platform, Flow developers took some liberties and the migration is not quite as painless as one would hope… :) Anyway – on to the topic of the day! Problem This…Continue reading How to fix a Logic App deployment that failed with error “ApiNotFound”?

"This is fine" - a fine meme, I mean.

How to fix “LinkedAuthorizationFailed” when deploying an Azure Logic App?

This article explains one possible fix to “LinkedAuthorizationFailed” when you’re deploying a Logic App from a Azure Automation template. Maybe it’ll apply to other cases, too – but in my case, it helped me fix a broken template I had exported from Power Automate, and was bringing into Logic Apps. Problem So, another fun issue to solve! The actual error you run into might be something along these lines: The client has permission to perform action ‘Microsoft.Logic/integrationAccounts/join/action’ on scope ‘/subscriptions/[your subscription id here]/resourcegroups/[your app resource…Continue reading How to fix “LinkedAuthorizationFailed” when deploying an Azure Logic App?